Free Final Cut Pro plugin: Bad TV a4d effect

There is a version of Bad TV in Final Cut Pro X, but the version available in Motion has more controls. I’ve produced Bad TV a4d:

Here are some examples of different looks using the effect:

Here are the controls:

Waviness: Sets the maximum horizontal distortion.

Roll: The vertical position of the clip.

Color Synch: The amount that the red, green and blue components are offset from each other.

Saturate: How much colour is added or taken away from the clip.

Number of Scan Lines: How many scan lines are added to the clip.

Scan Line Brightness: How much brighter the scan lines seem than the clip.

Scan Line Proportion: The thickness of the scan lines.

Static: The amount of static noise added to the clip.

Static Blend: The blend mode of the noise – changing this helps the static become more visible if your clip is primarily very dark or very light.

If you turn on video animation curves, you can use them to control the speed that the image rolls:

In this case the clip will roll up, roll down and roll back to the original value.

Installation

Download this disk image:

It includes an installation script for Spherico’s Motion Template Tool application, if you don’t have it on your Mac, download it. It is a freeware/donationware tool that simplifies effects installation for Final Cut Pro X users. MTT installs effects for Final Cut Pro X in the correct folders, creating them if need be. You don’t need to have Motion 5 or MTT installed for these effects to work.

Once you have MTT installed on your computer, double-click the ‘Install Bad TV a4d 1.0.mtt’ file.

If you don’t want to use MTT, install these effects in Home / Movies / Motion Templates / Effects / Stylize:

If you find this free plugin useful, you might like my Alex4D Animation Transitions plugin pack:

Find out more about Alex4D Animation Transitions.

There are many more free plugins on my Final Cut Pro X page

16-free-effects

28 comments
  1. Andrés Rivillas said:

    muuuuchisisiismas gracias alex!!!!!!!!!!!!!!!!!!!!!!!! NICE<!!!

  2. Sveinung said:

    I absolutely love this plugin! Been looking for a good one like this for quite some time now, thanks! 😀

  3. Mário said:

    Hello, very interesting plugin indeed! But It doesn’t work on my computer. I follow all your steps (and I did it with and without using MTT), then I’am able to see the effect and its thumbnail on Final Cut, but when I try to apply it I see only a blue screen. The controls are missing too. Have any tip as for how can I solve this problem? Thanks in advance!

    • Alex said:

      Make sure your running the newest version of FCP X. Use the App Store to update it to at least 10.0.4.

  4. Dave © said:

    This is really sweet! Thank you so much!!!

  5. Love this effect! One question: when it’s applied there’s sort of a reddish colored ghost, which i cant seem to find an adjustment setting for. What’s the best way to have the effect only flicker on and off for a second, by keyframing the adjustments? or is there another way to remove that ghost?

  6. Hey Alex, Is there a way or plugin that can make the footage roll in a horizontal direction as opposed to the vertical roll?

    • Alex said:

      There’s an effect in Motion that does what you want, so I’ve published it as a Motion template so you can use it in Final Cut Pro.

      Download it from http://www.alex4d.com/plugins/fcpX/Offset_a4d.zip

      Put the ‘Offset a4d’ folder in Motion Templates/Effects/Alex4D

      • Thanks Alex!!!

  7. Ras said:

    thanks!!!!!!!!!!!!!!!!!!!!!!!! <333333

  8. I was using this the plugin for a project but i’m on another computer now and can’t seem to download it. Is there any chance you could reupload?

  9. Uri said:

    Hi Alex, after the upgrade to big sur the gamma a4d and bad tv a4d plugins went missing from my project and also disappeared from the Motion Templates folder. it is still in the effects column of fcp but without its controls. i dowloaded the plugins again. How do i reconnect them to the non active effects in the timeline? i’m desperate. please help! thanks

    • Alex said:

      Try resetting the preferences in Final Cut. This is a Final Cut/macOS problem.

      Sadly there’s nothing _I_ can do to make a new version of these effects that gets around this Final Cut bug. The majority of plugins in Final Cut were created around the same time and in the same way as I made these – in Motion. The Motion template format hasn’t changed for Final Cut.

      It is possible that Final Cut won’t use the plugins applied in old timelines because they are now installed in a different place than before. If a plugin was installed in
      ‘Users/Uri/Movies/Motion Templates/Effects/Stylize’
      when you applied it and this time it is in
      ‘Uri/Movies/Motion Templates/Effects.localized/Stylize’
      then Final Cut won’t find it when you open the timeline.
      This can happen because
      A. Final Cut will see the effect if it is in either location and
      B. The Finder doesn’t show the ‘.localized’ suffix.

      To see where Final Cut found the effect before…
      1. Go to an older timeline and export XML
      2. Create a new timeline, apply the effect from the templates browser and export XML.
      3. Compare the locations of the effect as listed in the XMLs – each for ‘a4d’ to find the section of the XML where effects are listed.
      4. If the location of the plugin in the new timeline doesn’t match the old timeline, move the plugin to the old location.

      • Uri said:

        thanks for your reply Alex. i compared the 2 xmls, as you suggested. the old xml (with the missing plugins) doesn’t show their location. only the new one, with the reapplied effect, does. what can i do?

  10. Uri said:

    just to make it clear…
    the old one without address:

    the new one with address:

    • Alex said:

      I don’t see any locations here. Try entering new ones’s effect location without slashes but with spaces instead

  11. Uri said:

    new xml:

           

    old one with missing plugins:

           

  12. Uri said:

    is there another way of sending them to you?

    • Alex said:

      Not with the XML around it, something like

      file:///Users/Alex/Movies/Motion%20Templates.localized/Effects.localized/Stylize/Bad%20TV%20a4dBad%20TV%20a4d.moef

      In this case the Motion Templates and Effects folders have secret ‘.localized’ suffixes. If this is the current location of the plugin, I would move the ‘Bad TV a4d’ folder from ‘Motion Templates.localized/Effects.localized/Stylize’ to ‘Motion Templates/Effects/Stylize’ restart Final Cut and see if the old timeline finds it.

      You can see the true name of a folder in the Finder if you use the Get Info command with it selected.

  13. Uri said:

    I tried moving the plugins to folders without the ‘.localized’ suffixes. the timeline didn’t find it. i asked a friend to open the xml on her computer after installing the plugins. The gamma and bad tv effects are gone from the project. is it because the plugins don’t have a location in the old xml?

    • Alex said:

      Yes. Sadly, there’s nothing I can do. I have no new way of making new versions of Final Cut plugins that can fix this. Do you have have a backup of your library from before you updated Final Cut that you can share with your friend? Maybe your friend can export an XML from that version of the timeline.

  14. Uri said:

    If she has the same version of macOS and fcp as i do, won’t we get the same result?
    is it possible to add a location in the xml, instead of the missing one?

    • Alex said:

      It is hard to know what will make the difference. If it is an old backup of the library from before you upgraded to Big Sur, that might produce a different result.

      As regards editing the XML… maybe? You’ll need an ‘effect id’ line in the XML with something like

      effect id=”r2″ name=”Bad TV a4d” uid=”~/Effects.localized/Stylize/Bad TV a4d/Bad TV a4d.moef” src=”file:///Users/Uri/Movies/Motion%20Templates.localized/Effects.localized/Stylize/Bad%20TV%20a4d/Bad%20TV%20a4d.moef”

      • Uri said:

        i tried it on a computer that has the same macOS. the effects are still missing from the project. i’ll try to do this on a computer with an older version, but finding one might take too long.
        i don’t have the necessary understanding of xml to write lines. do you know anyone who can do this for me? i’m willing to pay for it. i can’t lose this project. redoing all the work is impossible.

  15. Uri said:

    with the Bad Tv a4d i could at least deactivate the effect, and the red screen would be gone.
    it is different with the Gamma a4d, which is applied to a different track\layer. When I delete the effect from the effects list, the red screen with two squares and exclamation mark only changes to the screen with missing plugin. but there are no other missing plugins. How can I get rid of it?

Leave a Reply to Andrés Rivillas Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: